YAML error with RV Package


I’m trying to write my own RV package, and I keep running into this error when adding my package:

“YAML parser failed on PACKAGE file in” [File Location]

I’ve ran my package file through a parser online with no errors, and tried changing the extension to .txt, .yml, .package, as well as removed the extension completely: all produced the same error.
My yml code is as follows:

package: OpenEdit
author: Philip Franjo
organization: Tonic DNA
contact: support@shotgunsoftware.com
version: 1.0
requires: ''
rv: 7.3.1

- file: OpenEdit
  load: immediate

description: |
  <p>Description of package here.</p>

Thank you,

-Phil F

The only thing I can see that looks suspicious is the file name. Is the file that contains the mode really called “OpenEdit” without an extension at all? All the cases I’ve seen have either had a .py or .mu extension, so it might be expecting some kind of extension.

I changed this to to the full filename (with the .py) and got the same error, “Could not copy files” and then in console YAML parsing error. :frowning:

Update on this, I copied the exact formatting from another package already loaded into RV. I don’t know if this was the fix, but what the biggest difference between the example PACKAGE code from How do I write my first package in RV? is:


  • file: OpenEdit.py
    menu: ‘Tools/OpenEdit’
    shortcut: ‘’
    event: ‘’
    load: immediate

Instead of what was provided, which is:


  • file: OpenEdit
    load: immediate

After that was replaced, the package loaded in successfully.