Shotgun Desktop Issue on CentOS 8.x


Its been a while since I’ve checked out Shotgun Toolkit updates so I setup a new test site, downloaded the desktop app and setup a default pipeline configuration. All of this is on a CentOS 8 machine with the most recent Shotgun releases as of today. After the pipeline config setup is complete, Shotgun Desktop seems to error out when trying to load the project information:

2020-11-05 11:30:49,173 [   DEBUG] Starting RPC server
2020-11-05 11:30:50,237 [   DEBUG] : Resolved hook expression (associated with setting 'hook_launch_python'): '{self}/' -> ['/home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-desktop/v2.5.9/hooks/']
2020-11-05 11:30:50,238 [   DEBUG] Loading environment data from path: /home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-config-basic/v1.3.15/env/site.yml
2020-11-05 11:30:50,255 [   DEBUG] launching '/home/sshrestha/apps/vfx/Shotgun/Python' '/home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-desktop/v2.5.9/' '-d' '/tmp/tmpg_BUEv.pkl' '-u' '/home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-desktop/v2.5.9/python/utils/'
 [   ERROR] Unexpected error while launching Python:
Traceback (most recent call last):
  File "/home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-desktop/v2.5.9/python/tk_desktop/", line 1507, in _start_bg_process
  File "/home/sshrestha/.shotgun/noizfactory/site.basic.desktop/cfg/install/core/python/tank/platform/", line 582, in execute_hook
    resolved_hook_paths, self, None, base_class=base_class, **kwargs
  File "/home/sshrestha/.shotgun/noizfactory/site.basic.desktop/cfg/install/core/python/tank/", line 631, in execute_hook_method
    ret_val = hook_method(**kwargs)
  File "/home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-desktop/v2.5.9/hooks/", line 62, in execute
    subprocess.Popen(args, startupinfo=startupinfo, close_fds=True)
  File "/home/sshrestha/apps/vfx/Shotgun/Python/lib/python2.7/", line 394, in _init_
    errread, errwrite)
  File "/home/sshrestha/apps/vfx/Shotgun/Python/lib/python2.7/", line 1047, in _execute_child
    raise child_exception
OSError: [Errno 13] Permission denied

While debugging this, I tried running tank and that also failed:

Cannot find interpreter /home/sshrestha/apps/vfx/Shotgun/Python defined in config file /home/sshrestha/workspace/storage/configs/fractaldemo/config/core/interpreter_Linux.cfg!

The path “/home/sshrestha/apps/vfx/Shotgun/Python” that’s setup in the interpreter config file seems wrong as it points to the shotgun python directory and not the python executable itself. So, I updated that config to point the right executable file “/home/sshrestha/apps/vfx/Shotgun/Python/bin/python” and everything seems to work fine now. I don’t remember having to do this additional step during toolkit setup in the past so I’m wondering if this is something specific to the newer CentOS/RHEL 8.x versions?

CentOS 8.2.2004 (kernel 4.18.0-193.28.1.el8_2.x86_64)


1 Like

I have the same issue on the latest kernel for Centos 8, while it worked int he previous Centos8 kernel.

I have the same [OSError: [Errno 30] on mac 10.13.6.
Any help or new idea in the new year ;)?

We’ll discuss this internally and respond back here.

@Tanguy were you able to solve the issue by following the same steps as @sachin.shrestha?

@Francesc_Macià it looks like your error might be a bit different? You have the error code 30 rather than 13. If it is different we can start a separate topic for that one.

Hi Philip, sorry my typing mistake the error code is 13!

1 Like

OK we’ve managed to recreate the issue with that version of MacOS as well. Newer versions of MacOS don’t appear to have the problem. We’ve created an internal ticket for this and can update this thread when we have more information.

As for CentOS 8 we don’t currently support that OS, but it’s possible that if we find a fix for MacOS then it might also apply to CentOS 8 as well.


I did not try that, I just used Mate desktop instead of the regular gnome. My issue was that the SG toolkit was unable to display the icone within the regular gnome desktop shipped with Centos8.
Now my setup works fine with Centos8, BUT on Mate Desktop.

I’m also trying to setup on centos8. Is there a fix in the pipeline for this or should I report back to my client that centos8 is a non-starter for the foreseeable future?
@Tanguy Do you have a simple guide to hand that I can use to install Mate? The one I found was pretty scary looking Install MATE on CentOS 8 - Tyler’s Guides (

Hi Patrick,

I used this method:

It works but I had some instability (somehow) but not sure it was related.
I stepped away from CentOS since their announcement, I am on Mint cinnamon now and definitely happy with that. Rocky has a mate install if am right.


I love mint cinnamon… great setup!

Tyler’s method is not that far but the coprs on is super stable in term of OS and straight forward to install. Specially when HE is the one doing the port.
On the other end, at the end, beside Maya being a lil bit of a annoyance to install (even not that bad though since Autodesk supports it on their website (still a hack) but an Autodesk hack. I guess next year we will see a proper generic installer like Nuke or Houdini.
I use mainly Houdini and Nuke with a bit of Maya indeed, Substance and the likes, including Redshift / Arnold and RM. Octane some how but yet mature enough for my needs. So all those are happy campers in my Mint install.
The perks though coming with the switch is that the ecosystem in Ubuntu world is WAY richer than Centos or RPM in general. First time I did not have any trouble finding any tools I need for my day to day operation, aka renamer, screenCapture with auto upload etc.
All those are indeed available somehow in Centos BUT you need to use Snap. I am not super duper happy with some snap Desktop integration. You install and it is not showing up in your GUI and using the snap CLI to launch is cumbersome to me. I am a CLI guys, don’t get me wrong but Snap command line is a PITA.
Hope it helps,