Setting Pipeline configuration when bootstrapping with path descriptor


I’m trying to set my pipeline configuration while bootstrapping to run an engine.
I tried to set it with

mgr.base_configuration = sgtk:descriptor:path?path=/my/absolute/path

But I get the following error:
TankBootstrapError: Configuration could not be installed: Could not get latest version of Toolkit App Store Core latest. For more details, see the log..

But I don’t want any downloading, I just want to use the config already existing at “/my/absolute/path”, which is not under me project. How can I achieve this?


Hi Alex!

A couple things to note here:

  • It looks like your pipeline configuration doesn’t include a core/core_api.yml file. This file specifies a version of tk-core, and without it, the bootstrap process will try to get the latest version of core. You’ll want to add that file and ensure that the version of tk-core that you specify there is in fact cached on disk.
  • Also, it’s worth noting that by default, the config that you specify as base_configuration will only be used if there is no PipelineConfiguration for the project in Shotgun. If you want to ensure that that config is used, you can do one of the following:

Hope that helps! Let us know if you still have questions!


Hi Tannaz,

Thanks for your answer. I added the core_api.yml file and I don’t have any download attempts, thanks.
I still have issues however. How can I disable the local caching of the configuration?

To be more specific, I need to be able to specify (via env variable I suppose) the path to the pipeline config I want to use, without downloading any app, engine, core, config or caching anything. Is it possible?


It should be possible, but only if you already have all the required dependencies in your bundle cache. If you set the env var SHOTGUN_DISABLE_APPSTORE_ACCESS, then it will block it from trying to download the bundle items, however it willl still hit an error if it can’t find the bundle item in the cache.


Hi Philippe,

I already have this variable set to and I have the error you mention.
Is it possible not to have a bundle cache but just a config with all required dependencies, and set its path somehow for sgtk so it uses it directly without any copying or whatnot?


So you can include the bundle cache in the config itself, but that does mean your config becomes quite large.

Or you can define the SHOTGUN_BUNDLE_CACHE_PATH or SHOTGUN_BUNDLE_CACHE_FALLBACK_PATHS environment variables to point to a location where all the bundles can be found.