RV Crashes when user edits value already in RV_PREFS_OVERRIDE_PATH

Hi! I might be missing a step? Here is my way to reproduce the crash, tested in Linux with 7.6 and 7.5 and in Mac with RV 7.6

1 Delete your .plist or .conf from your settings folder as described in the manual:
(centos) rm -f ~/.config/TweakSoftware/RV.conf
(darwin) rm -f ~/Library/Preferences/com.tweaksoftware.RV.plist

2 Open RV and tweak one setting for example “Max Look-Ahead Wait Time” type in 7 secs.

3 Close RV to save preferences

4 Copy the newly created file to a folder:
(centos) cp ~/.config/TweakSoftware/RV.conf /path/to/conffolder
(darwin) cp ~/Library/Preferences/com.tweaksoftware.RV.plist /path/to/conffolder

5 Delete all the licensing stuff inside the file and leave only the caching_bufferwait variable with the value of 7, in the case of osx under ROOT and in the case of linux under [caching]

6 Delete again the user local conf file as in step 1, to simulate a fresh install of RV (This is important otherwise it won’t crash)

7 Set the env variable to the folder with the studio conf:
export RV_PREFS_OVERRIDE_PATH="/path/to/conffolder"

7 Open RV, type your license settings or login, open preferences, “Max Look-Ahead Wait Time” should have the value of 7, type any other value like 3.

8 Close RV Preferences dialog to save the preferences.

RV Crashes.

If you edit a value that is not being set by RV_PREFS_OVERRIDE_PATH it doesn’t crash and both values work fine and are saved.

If you use the RV_PREFS_CLOBBER_PATH instead of the override one, it does not crash.

If the value was already set by the user in his local settings, before setting the env variable, it does not crash.

In one linux machine it does not crash, however the value does not get saved, like if it was being set by the clobber path instead of the override one.

Hey Macbeth!

This sounds like an issue we’re aware of and it’s currently in progress. Please be on the lookout for RV 7.6.1 later this month, as that release will contain the fix.


1 Like

Hi thanks for the info!
Is there any workaround meanwhile?

I had to move my config to the clobber path so at least it doesnt crash.

But I found another issue; I want some packages to be auto loaded as a default config for users (clobber will be ok for now) but if I set some packcages in my RV.conf like this:


Then users are not able to set any other packages on.

Like if defining one package sets the clobber config for ALL the packages.

Is there a way to set some packages to be on by default, but allow users to turn on other packages if needed?

Thanks in advance!