Nuke - Shotgrid Writenodes error - UnicodeDecodeError

Hello group,

So we’ve updated to Nuke 13 and now we are facing some showstopping errors with the Shotgrid writenodes.
When we have a SG Writenode in our script and try to save (either true the regular save of via the SG File Save dialog, we get the following error:

File “C:\Users\info\AppData\Roaming\Shotgun\bundle_cache\app_store\tk-nuke-writenode\v1.6.0\python\tk_nuke_writenode\”, line 1618, in __update_render_path
if force_reset or not last_known_script_knob.value():
UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xc0 in position 10: invalid start byte

Also, in the Nuke DAG we see the same error ‘‘utf-8’ codec can’t decode byte 0xc0 in position 10: invalid start byte’ on the node itself.

The SG writenode app is vanilla and worked fine in Nuke 12.
All the Apps and Engines are updated to the latest versions.

Anybody a clue what’s going on here?



Seems like a python 3 compatibility issue. Nuke 13 has switched to Python 3 (Nuke 12 was python 2.7).

I would also recommend to set up staging environements so you can test software upgrades without affecting your current pipe and validate if all works correctly before switching over the rest of the studio.

Hey Ricardo,

It’s in a staging area obviously :wink: It’s not rolled out yet, but the artists like to upgrade soon.

Yeah I suspected something like Python 3.
I made all the rest of the scripts Python 3 compatible already, but I like to keep most of the Apps “Vanilla” so it’s easier to update.

But it’s kind of a pickle because it appears to happen in de writenode app itself.
Saving Nuke scriptwhich have sg writenodes in them causes Nuke to crash immediately.



1 Like