Max resolution from image uploads

I’ve been noticing some issues with thumbnail creation when still images with giant resolutions are published.

For example, there was a publish of a jpeg with a resolution of 21000x16000 that would not upload.
I resized it by half and it worked.

Is there an upper limit to upload resolutions? If so might I suggest that the transcoder resize huge images to fit that upper bound instead of just not uploading and giving us no indication that there was a problem.



Hi @StarkRavenSimone,

Thanks for your message - our transcoder is intended to work as follows for still images:

  • If the media is below 2K, then its current resolution is maintained.
  • If one of (or all) the dimensions is above 2K, we snap the larger dimension to 2048, the other is adjusted according to the ratio of the original media. For example, a 3648x2736 JPG is transcoded into a 2048x1536.

So it should be downressing accordingly as opposed to not working. Is there any chance it’s working, just slowly in the BG since it’s a larger file? Have your tried opening the browser’s Javascript Console on upload to see if there are any errors reported there when you attempt to run through the upload process?

Do you have a sample image you could email to us at so we can take a closer look? You can copy and paste your original query and we can carry on in a support ticket.

Further reading on transcoding resolution:


1 Like

Hi Beth,

I don’t follow how the js console in the browser is going to tell me anything. I’m publishing through the SG app.
How does the SG web interface have any context to what the publisher is doing at any given moment?

I tried to publish it again just now. It’s possible its just taking a long time to transcode but I’ve tried multiple versions days ago that still don’t have thumbnails.

Nothing mentioned in the javascript browser. I’m not sure what I’m looking for at any rate.

Thanks for you help!

Hi @StarkRavenSimone,

Apologies for the confusion, I wasn’t sure if there was an error in SG that was preventing the upload from happening - sometimes the JS console will provide further info where it might be erroring out.

That being said, I spoke to our tech team and it looks like there is an upper limit to the resolution of still images as found in the documentation linked here.

Shotgun’s transcoding service is optimized to handle still image resolutions up to 8K (7,680 x 4,320 pixels)

It looks like your still images are exceeding that limit so the only way around it with our current transcoder is to downres your images before uploading.

Please let me know if you have any further questions!



Thanks for you help!