Integration Photoshop - Save and publish .psb files

I have troubles handling .psb files with Shotgun Integration:

• I open a ~2Go .psb file in Photoshop CC 2018. The file is saved on my local hard drive ‘E:/’.

• In the Shotgun Adobe Panel, I clic Save, chose the asset and task I’m interested in and enter a name for the file. The templates match, everything’s right, I clic “Save”.

• Rather than automaticaly save the file in the templated folder with the correct name like with psd, jpg etc, a classic “Save as” Photoshop window opens, pointing to the original folder ‘E:/’ without the templated file name.

• If I manually save the file in the correct folder through this Photoshop Save As window, I then won’t be able to reopen the psb file through the Shotgun Adobe Pannel. SG Integration acts as if it never registered the file.

Is it normal ? It’s really problematic, we want psb files to be saved just like any other psd file, as we don’t want our artists going around in folders or naming files by hand, and we want to be able to open our work from SG Integration




Hi Ben

Sorry you’re having issues. I just tried the same thing here, I launched Photoshop via SG Desktop, saved a new file to my desktop as a psb, and then opened the save app via the Shotgun panel.
Then in the save app I selected a task on an asset and saved the file (as a psd). The file saved into the correct location and the name changed accordingly. I didn’t get the Photoshop save as window poping up.

What your saying sounds unintended, but I’m not sure how to replicate it. I was on Mac, so I’ll boot up a VM and try on Windows just incase.

As for manually saving the file in the correct location, that should work, but you have to get exactly the right location and naming so that the file path conforms to the template, otherwise it will discount the file. As a test you could try creating a new file via the Shotgun open app, and then saving it, and see if the path or naming differs?

I’ll let you know once I’ve tested Windows.


1 Like

Hi Philip,
Thanks for your help.

Thinking about it, I think the problem comes from the way SGI uses the template: I did not customize the possible extension of photoshop file,s so my template should logicaly only use ‘.psd’ as an extension.
Photoshop can’t save a 2Go file as a psd.

I’m gonna try using the a extension key for photoshop, just like on maya:

>     # Maya supports two extension types.
>     maya_extension:
>         type: str
>         choices:
>             ma: Maya Ascii (.ma)
>             # mb: Maya Binary (.mb)
>         default: ma
>         alias: extension


>     # Photoshop supports two extension types.
>     ps_extension:
>         type: str
>         choices:
>             psd: normal files (.psd)
>             psb: bigger files (.psb)
>         default: psd
>         alias: extension

I’ll keep you posted.


Do you have an idea how to add the possibility of extension choice in the ‘save as’ UI? Even after changing the templates to add a ‘choice’ key, I can’t change extension in Photoshop Integration, which only uses ‘psd’.


1 Like

Hi Ben

I tried the same thing, but it did give me the options:

Did you update your template to use the key?

        type: str
            psd: Photoshop (.psd)
            psb: Large Document Format (.psb)
        default: psd
        alias: extension


        definition: '@asset_root/work/photoshop/{name}.v{version}.{photoshop_extension}'

And did you restart the integration or Photoshop?


It did not seem to work using the ‘Reload App & Engine’ button, but restarting Photoshop it worked!

Thanks Philip.