Houdini 19 and tk-houdini 1.8.1 Startup Errors

We are migrating over to the newly released Houdini 19 for kinefx features, and we’re getting hit out of the gate with:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.383/houdini/python3.7libs\viewerstate\utils.py", line 948, in register_pystate
    mod = importlib.import_module(module_name)
  File "C:\PROGRA~1\SIDEEF~1\HOUDIN~1.383\python37\lib\importlib\__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1006, in _gcd_import
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 728, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "C:\Users\user\AppData\Roaming\Shotgun\bundle_cache\app_store\tk-houdini\v1.8.1\python\__init__.py", line 10, in <module>
    from .tk_houdini import *
  File "C:\PROGRA~1\SIDEEF~1\HOUDIN~1.383\python37\lib\site-packages-forced\shiboken2\files.dir\shibokensupport\__feature__.py", line 142, in _import
    return original_import(name, *args, **kwargs)
ImportError: attempted relative import with no known parent package

This has the effect of not being able use the Show/Edit Handle tool when building rigs, for example. The Houdini-Python eco system seems to have changed significantly is this release, I’m hoping there’s a fix for it?


Thank you for your feedback. ShotGrid Toolkit integration does not support Houdini 19 yet. You can see the list of our supported versions here: Engine Supported Versions - SG Developer

Support for Houdini 19 is on our roadmap, so please do not hesitate to post other issues you might found with that version.


Thanks for getting back to me Francis, is there an ETA for support of 19?


Hi Adam,

Sorry, no ETA for now.


Just a quick follow up to this… it seems like the issue is actually caused by a python viewer_state loading mechanism that erroneously calls a few ambiguous relative imports. The tk-houdini error happens to be a red herring. We fixed it by hacking the shipped houdini scripts… which I don’t recommend…


That’s strange, because here I’ve been using H19 with toolkit since beta and I didn’t have the errors you reported.

Based on our first investigation it seems happening only on Windows and Linux, not on mac. Also it is only happening with an advanced integration.

I’m on windows too and I’m using a very customized pipeline too…

It is easy to miss, since it appears to be specific to the kinefx__skeletonstate module. We found that without our hack, if you drop a skeleton sop, for example, the handle tool is broken (cannot draw bones etc).

I’ve reported that in the beta but they took some time to figure that out. It has been fixed:

Houdini 19.0.435 : Fix an issue related to viewer state module loading that was causing the Skeleton SOP state to be missing when 3rd party packages are installed.

1 Like

Fantastic, thank you for pointing that out!
(We’ve only ever installed the production builds)

I wouldn’t call the gold release “production”! haha

Apparently Houdini19 is still not supported by tk-houdini 1.8.1. We are getting this error that its generic visualizer is clashing with the one bundled with houdini19.

Traceback (most recent call last): 44 File “C:/PROGRA~1/SIDEEF~1/HOUDIN~1.383/houdini/python3.7libs\pdgd\types_init_.py”, line 63, in registerPythonModules 45 pdgd.TypeRegistry.registerModuleTypes(module, True) 46 File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.383/houdini/python3.7libs\pdgd_init.py", line 110, in _registerModuleTypes 47 module.registerTypes(pdgd.TypeRegistry.Instance()) 48 File “C:/Program Files/Side Effects Software/Houdini 19.0.383/houdini/pdgd/types\genericvisualizer.py”, line 74, in registerTypes 49 type_registry.registerVisualizer(GenericVisualizer) 50 File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.383/houdini/python3.7libs\pdgd_init.py", line 95, in _registerVisualizer 51 return self._registerVisualizer(type_object, name, label) 52RuntimeError: A type already exists with the name genericvisualizer

I’ve been using SG with H19 from the beginning successfully. What are u trying to do?
You are using the H19 gold (buggy) version right? Anyway, you should try the newest production build…

Thx… I will try