"Cut Item In/Out" is always one frame off

Hi all,

I hav written a tool to send overcuts from Hiero directly into SG. In order to make it match frame by frame I have to increment the actual first frame used in the cut by one.
E.g. if a version’s first frame in the cut is 1009 I have to set SG’s “cut item in” to 1010. Same with the last frame.

Can somebody help me out here and explain wy this is?

this is only true for teh VFX shots, the base media layer is fine and matches both in numbers and picture. I am suspecting the slate that sits at frame 1000 but can’t pin it down.


Do you have audio with these? And have you checked to see if you get the same issue using Safari?
I experience something similar but it’s because in my tool I mux in audio and need to start it a frame later because of the slate.

thanks for the reply @dschwarz !
Yes, the movs do have audio and a slate.
I can obviously fudge it to make it line up for this particular cut, but I am trying to write a generic exporter so I need to understand when this offset needs to happen in a way that will always work.

I have not tried on Safari (I am mostly working on linux and my colleagues on windows)

Sorry for the late reply. So the playback issue for me would happen on Chrome or Firefox but not Safari playing back in g SG which means it was playing back the SG transcoded video but for me to get it to work properly we had to also mux silent audio in our FFMPEG job that starts at frame 0. SG player in Chrome does not like video that has no audio at the very beginning of the video.
I feel this is an issue with SG player that should be addressed and I’m pretty sure it was reported.
Actually I need to go check to see if it is still happening they very well could have fixed it.

Thanks I have parked this for now as we are getting too busy. But would be good to see fixed

1 Like