Adding software integration disrupts other

I had been having problems getting Photoshop to run through integrations with Shotgun. Maya and Unreal worked just fine.
When I created a new project, Photoshop worked.
When I then added Unreal ( using from Adv Proj Setup) Photoshop stopped working. It can now not be launched from any of the integrated applications, however Maya still works and I now have access to Unreal.

Has anyone had this issue occur?

Running that advanced project setup completely replaces your used toolkit configuration, so it is not surprising that some things stopped working. You need to see whether tk-config-unreal has some differences with tk-config-default2.
Maybe this pull request will fix it for you, because it updates the Photoshop engine to 1.8.2.

You can also run ./tank updates in the project’s folder, and engines and apps will be updated, which might also fix it for you.

Edit: when you pull a config with updated versions, perform
./tank cache_apps
to download the necessary packages, otherwise you’ll get errors.