Thumbnail upload error

Hey there!

I just noticed that suddenly i get an error when trying to publish something from our stand-alone publisher. To be sure I just updated its version to 2.5.3 and am using the default hook for publishing, but the same error occures:

ShotgunPublishError: Unable to complete publishing because of the following error: 
Could not upload file successfully, but not sure why. 
Path: ...lalala.PNG
Error 0
undefined method '[]'for nil:NilClass, although Published File lalala.PNG (id: 20178) was created.

As the error states as well, the publish is created but is missing its thumbnail.
It could have something to do with an SSL error I got previous to this but i managed to fix that by setting an environment variable (SHOTGUN_API_CACERTS).

Any help would be very much appreciated


Hi Jonas!

This may be due to a bug we’re about to fix. Essentially the Published File entity is missing the filmstrip_image field and when a process tries to upload to it, it fails. Work is in progress on a fix, and we can report back when it goes out.


Hey @brandon.foster,
We are still encountering this error and are not able to publish from the stand-alone.
Are there any updates to this?


Nothing concrete, unfortunately. The fix is still in progress by the engineering team. As soon as it’s completed we’ll share it here.


Hi Jonas,

Sorry for the delay in getting back to you for this one. For some reason the release notes for this fix didn’t make it out, but that’s been corrected now. Can you confirm you’re able to successfully upload to the Published File thumbnail field now?This text will be hidden

1 Like

Hi Brandon,
unfortunately i am still getting the same error. Is there something I need to update from our site?

I just noticed, that the error message changed a bit:

Instead of saying “undefined method…” it now states “Upload file is forbidden”

thanks for your reply

1 Like

Could you open a support case with us ( along with your site URL and log files (desktop and the publisher) so we can dig deeper into this?


I’m suddenly getting the same error, the only code I’m running from Standalone API is:

thumb_file = (os.path.join(os.path.dirname(file), “thumbnail.jpg”)).replace("\", “/”)
sg.upload_thumbnail(“Version”, sg_version[“id”], thumb_file)