RV force single frame

Is there a way to set RV where it does not automatically view images as a sequence? In the following RV session I would like to see 17 individual frames, instead of the range 1, 5-20.

Screen Shot 2020-10-29 at 3.31.04 PM

Is there either a hotkey to toggle the frame sequence off, or a preference to have RV read the files as individual frames from the start?

Is there no way to do this?

The only way I know is to disable File/Options/One File → Sequence and then load all 17 images separately into RV.

1 Like

There is an environment variable called TWK_MIN_SEQUENCE_SIZE that allows you to set the number of files from a sequence required before RV will automatically concatenate the individual files into a sequence.

It’s mentioned in some old release notes: RV 4 Release Notes

Hi @Missy_of_Science, it appears that there may be a bug in my menus. When I expand File > Options it does not reveal a sub-menu. Even though I have the little caret where it should have one. When I click on “Options” it just closes the menu as if that is a selection, not a parent menu:

File/Options/One File → Sequence is a result of an optional package that is loaded, and Options is only filled out when a package places a menu there. I’m pretty sure newer RV versions remove that menu by default until a package places something there to avoid the confusion.

This is indeed true. If you set that environment variable to a very high number, you’d get the behavior you are looking for, but it would affect everything (so you’d effectively never be able to load in a sequence).

Your best bet would be an alternate scripted File>Open Images Without Sequence.

You could essentially use commands.existingFilesInSequence to determine what frames exist, then run a commands.addSources with each frame specified as a sequence individually and add the +noSequence modifier (which is the -noSequence`)

This is the analog to doing rv <file1> <file2> <file> ... -noSequence