Sequence form not opening


first of all, I must say that I’m a Shotgrid noob, so sorry if I ask a silly question :slight_smile:

I am setting up my first project; I was able to create a list of assets, a list of shots and one sequence.

I would like to add more sequences, but when I click on the + button (top right) and select Sequence from the dropdown menu, the Form popup does not appear, the browser window just turn blank

I tried creating a new sequence from the shots list: I select a shot and in the sequence column I digit the name I would like to assign to the sequence, then I select Create new sequence from the dropdown menu, and the window turns blank.

I am working with Chrome (v. 91.0.4472.77); i tried also with Microsoft Edge, but nothing changed. I also tried with my brother’s PC and the problem still remains.
Is anyone experiencing the same problem? Is there a workaround to create a sequence?

Thanks to all in advance!

1 Like

Hi Camilla,

From that behavior it sounds like there may be something either corrupted with your Sequence entity, or for some reason the Sequence itself may be turned off for the Project in which you’re trying to create your Sequence. The former would need to be fixed by support, while the latter you can check by looking at your Project Tracking Settings.